System requirements

Last modified by superadmin on 06.12.2019

The Xima® Formcycle Server is a Java web application run on a Java web container or application server.

Software

Server

The following software is required for a Xima® Formcycle Server.

  • Oracle Java JDK, version 1.8.x or higher (OpenJDK is not supported.)
  • Apache Tomcat 8 or JBoss
    Tomcat versions 8.5.48-49 contain a bug that prevents Xima® Formcycle from running. For Tomcat versions from 8.5.50 onward, this bug is fixed.
  • Other applications server are possible, but are not officially supported.

Database

One of the following database management systems must be installed.

  • MySQL, version 5.1 or higher (currently until the last version of 5, because of changing the system specific names in version 8)
  • MS SQL, version 2008 R2 or higher
  • Oracle, Version 11 or higher
  • PostgreSQL, version 9.1 or higher

Browser (administration interface)

These requirements exists only for the administration interface of Xima® Formcycle, not for opening and filling out forms.

  • Microsoft Edge
  • Mozilla Firefox 3.6, or higher
  • Google Chrome 13 or higher

Currently, we recommend Mozilla Firefox.

Hardware

Hardware requirements may differ depending on how Xima® Formcycle is used, eg. how many forms have to be processed each day.

Consider the following requirement on the system:

  • 1 client
  • 40 forms
  • 1000 form submissions daily
  • 1000 state transitions daily 
  • 500 files created by action, eg PDF or Word files
  • 10 simultaneously registered users processing submitted forms

This will require the following hardware:

  • Windows 2008 R2 (64-bit) or Linux (64-bit)
  • 2 x QuadCore processors @ 2,8 GHz
  • 8 GB RAM (4 GB for the application server)
  • 10 GB disc space for XIMA® FORMCYCLE

Database(s) are kept on a separate server.

Tags:
Created by superadmin on 22.06.2015
Translated into en by superadmin on 26.07.2016
  
Copyright 2000-2018